求助 pxc 安装过程遇到openssl的问题?


1.jpg

系统版本是CentOS6.X,一开始发现没有 libssl.so.1.0.0 和libcrypto.so.1.0.0 文件 openssl 我是yum直接安装的。
OpenSSL的版本是下面这个
OpenSSL 1.0.1e-fips 11 Feb 2013。
 
我的解决思路是,
在usr/lib64 下面直接做了2个软连接
 ln -s libssl.so.1.0.1e libssl.so.1.0.0
 ln -s libcrypto.so.1.0.1e  libcrypto.so.1.0.0
然后在
/etc/ld.so.conf.d 添加了
/usr/lib64/mysql
/usr/lib64
然后ldconfig 
发现数据库初始化时候还是提示
./mysqld: /usr/lib64/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mysqld)
./mysqld: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./mysqld)
./mysqld: /usr/lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./mysqld)
 
开始怀疑不能直接使用 libcrypto.so.1.0.1e 于是自己下载源码编译libcrypto.so.1.0.0 依然失败,折腾了半天问题依然没有解决。
已邀请:

wubx - 专注MySQL及架构设计

赞同来自:

应该是下载错版本了。
CentOS 系列要下载 101那个版本。
Ubuntu 系列要下载100那个版本。

要回复问题请先登录注册